[Date Index][Thread Index]
[Date Prev][Date Next][Thread Prev][Thread Next]

Re: A question [FWD]

On Sat, Aug 08, 1998, Geir Eivind Mork wrote:

> On Sat, 8 Aug 1998 16:47:27 +0200, Ralf S. Engelschall wrote:
> >Seems like ePerl has some problems on your FreeBSD box with the
> >dynamic shared object stuff of Perl 5.005_01. Hmmm... Can you
> >please test if a simple and real Perl script
> >  #!/usr/local/bin/perl5
> >  use IO;
> >  1;
> Syntax error in file t.sh at line 2, next 2 tokens "use IO"
> execution of t.sh aborted due to compilation errors. 
> But when I installed perl 5.00401 again, it worked w/o problems. Strange I
> must say, but I'll use that version of perl forever if that's the only way
> to use WML, hehe.[...]

Yes, use 5.004. Unless you want to use Threads, the new Perl Compiler or
mod_perl (memory leaks in 5.004!) there is no real need to upgrade to 5.005,
of course. But it's strange, because on my FreeBSD box I've installed Perl
through the FreeBSD Ports, too. And it runs fine. Very strange... But ok, keep
5.004 running unless 5.005 is really stable... (i.e. 5.005_05 or such a
                                       Ralf S. Engelschall
Website META Language (WML)                www.engelschall.com/sw/wml/
Official Support Mailing List                   sw-wml@engelschall.com
Automated List Manager                       majordomo@engelschall.com