[Date Index][Thread Index]
[Date Prev][Date Next][Thread Prev][Thread Next]

Re: BUG REPORT: Website META Language 1.7.2 (28-06-1999)

On Sun, 5 Sep 1999, Gerfried Fuchs wrote:

>  I can't reproduce it really for myself for I have a running 1.7.2
> version at home (with SuSE 6.0 on the other hand)....  It's only that I
> haven't got a clue where to start searching for what's going wrong and
> I'm not handy with strace, gdb or that stuff. If one could give me a
> helping hand I would be greatful!

In fact, this is a perl problem, since this problem occur at pass 1. 

>  It happens when I both run wmk or wml on a single file. Maybe the error
> message itself is more of a help?
> alfie@skater:~/WWW/WML > ls -a
> ./              HELP            alfie.wml       index.html      music.wml
> ../             INCLUDES/       disclaimer.wml  index.wml       pics@
> .wmlrc          abb.wml         frame.wmk       missing.wml     wml.wml

``ls -la'' gives useful information, as ``head abb.wml'' does.

>  I hope someone has got a clue - it's a little annoying to always have
> to type "wmk -IINCLUDES" ;-/

Do you mean that everything is right when the -I option is on the
command line? So is your .wmlrc readable?

To debug this problem, turn on verbose mode. With

prompt> wml -v9 abb.wml

Take a close look at the line beginning with
** WML:Verbose: splitting to argv
If your .wmlrc is read, you should see ``|-I|INCLUDES|'' near the EOL.

Denis Barbier
WML Maintainer

Website META Language (WML)                www.engelschall.com/sw/wml/
Official Support Mailing List                   sw-wml@engelschall.com
Automated List Manager                       majordomo@engelschall.com