[Date Index][Thread Index]
[Date Prev][Date Next][Thread Prev][Thread Next]

Re: Upgrade problem



On Sat, 18 Mar 2000, Daisuke Yabuki wrote:

> Folks,
> 
> I tried some search regarding my issue and couldn't find postings 
> on a similar situation. I, therefore, expect this is not FAQ. 

Indeed your problem seems very special.

> I finally upgraded from perl-5.00404 to perl-5.00503 a couple of 
> days ago since 5.00503 was required by a software I was trying 
> to install, which was not WML, by the way.
> 
> Yesterday, I noticed wml was not working anymore. One problem seemed
> that wml was looking for the old perl modules. So I reinstalled 
> wml-1.7.4 using perl-5.00503, but it still didn't work.

This is indeed a feature.
[...]

> t/09-p9_slice.......Can't locate object method "Max" via package "" at /usr/local/src/www/authoring/wml-1.7.4/wml_test/TEST.root/lib/exec/wml_p9_slice line 662.
> ** WML:Break: Error in Pass 9 (rc=255).
[...]

> Something seems to go wrong with Bit::Vector, so I looked at
> $WML_PREFIX/lib/perl/lib/5.00503/sun4-solaris/Bit/Vector.pm 
> but couldn't fiture out what's wrong.
[...]

There is nothing i can do. Maybe you could download slice from
  http://www.engelschall.com/sw/slice/
and see if it works (slice comes with a test which is not included
into WML). This will give us useful clues.


-- 
Denis Barbier
WML Maintainer

______________________________________________________________________
Website META Language (WML)                www.engelschall.com/sw/wml/
Official Support Mailing List                   sw-wml@engelschall.com
Automated List Manager                       majordomo@engelschall.com