[Date Index][Thread Index]
[Date Prev][Date Next][Thread Prev][Thread Next]

Re: Problems moving from 1.7.4 to 2.0.1 (resent)

Hi Denis,

thanks for your reply.

> > I'm not sure why I get them, I assume they relate to the move to mp4h and
> > specifically the inclusion of /usr/local/lib/wml/include/sys/bootp2.wml,
> > but I don't know why I get them.
> The problem is that wml::sys::bootp2 is no more shipped with WML.
> Unfortunately, it will be loaded by wml if it exists.
> So you have to remove this file.

I doesn't seem to be that simple :-) When I remove the file, I get this:

wml about.wml --include=include-2.0   -o '(ALL-LANG_*)uLANG_E:about_e.html' -o '(ALL-LANG_*)uLANG_D:about_d.html'
ePerl:Error: Perl runtime error (interpreter rc=1)
---- Contents of STDERR channel: ---------
** wml::des::ttfont:
** WML:Break: Error in Pass 3 (rc=74).
make: *** [about_e.html] Error 1

Right now it only works with the file bootp2.wml present.

> > (i.e. escape the quotes), is that a side-effect of the change to mp4h
> > too, or is that due to an updated ePerl?
> ???
> If ePerl complains, this means that <aspemail> is used within some ePerl
> commands. Could you send a more complete example?

I checked my code again, and couldn't find a reason why wml would think
this code is inside an ePerl section. I tinkered around with it and
suddenly noticed that the problem is gone with the latest
wml-SNAP. Whatever it was, it must have been solved sometime since 2.0.1
was released.

All the best,


Stephan Petersen                           sp@gtt.lth.rwth-aachen.de

>-=-=-=- Visit GTT's Technical Thermochemistry Web Page at =-=-=-=-<
>-=-=-=-      http://gttserv.lth.rwth-aachen.de/gtt/       =-=-=-=-<

Website META Language (WML)                www.engelschall.com/sw/wml/
Official Support Mailing List                   sw-wml@engelschall.com
Automated List Manager                       majordomo@engelschall.com