[Date Index][Thread Index]
[Date Prev][Date Next][Thread Prev][Thread Next]

Re: From version 1.7 to 2

On Thu, Aug 31, 2000 at 05:52:41PM -0400, Benoit des Ligneris wrote:

> Hello,
> Well, I just downloaded the last version of wml and I've got some trouble for passing from v1.7 to 2.0
> My navbars are all "scratched". Well, what I mean is that all the navbars and subbars are displayed
> by wml whereas I selected ony the main one !
> Here is the portion of code for navbars and how I "call" them :
> ============
> wml::home::ben-navbars2.wml
> ============
> #use wml::des::navbar
> <define-container subbar>
>   <if <or
>         <match "$(select)" "%0">
>         <match "$(parent)" "%0">>
>         <prog
> #         %body
>           > >
> </define-container>

Hi Benoit,

WML 2.x is shipped with a file called README.mp4h which give some
explanations about your problem.
You have to load wml::sys::compat1 or replace your <define-container>
tags with <define-tag xxx endtag=required>

You should also replace the <if> tags by <when>, which gives much more
readable input.

Denis Barbier
WML Maintainer
Website META Language (WML)                www.engelschall.com/sw/wml/
Official Support Mailing List                   sw-wml@engelschall.com
Automated List Manager                       majordomo@engelschall.com