[Date Index][Thread Index]
[Date Prev][Date Next][Thread Prev][Thread Next]

Re: eperl-mode for (X)Emacs

On Wed, Nov 22, 2000 at 07:48:28PM +0100, Thomas R. Koll wrote:

> I don't know much about settip up emacs, so I want to know where to install
> the files, I tried /usr/share/emacs/20.7/lisp but it didn't work. (My
> system is debian) I hope you can help me

First of all, my eperl-mode.el will not work in FSF Emacs, because it uses
extents.  It may be possible to use an overlay  compatibility library, but I
do not have time to do it right now.

I think that your problem is even more fundamental than that, as you do not
seem how to install add-on packages for (X)Emacs.  Just put the files in
some directory (say /path/to/dir/) and put that in your ~/.emacs:

    (load-file "/path/to/dir/eperl-mode")

Then, when visiting a buffer with ePerl constructs, just type

    M-x eperl-mode

and you are in business.    
Website META Language (WML)                www.engelschall.com/sw/wml/
Official Support Mailing List                   sw-wml@engelschall.com
Automated List Manager                       majordomo@engelschall.com